
General Workflow Instructions for capturing 360° images using Theta V, editing in Photoshop, and 
publishing to Google StreetView 

This document attempts to give step-by-step instructions for capturing and publishing 360⁰ imagery to 
Google Street View. It was created as part of a small mini—grant project in which the University of 
Northern Iowa GeoTREE Center (https://www.geotree.uni.edu/) worked with Orchard Hill Elementary in 
Cedar Falls, Iowa to go through process of capturing 360° imagery and publishing to Google Street View.  

This document was prepared by Ben Gavin and edited by John DeGroote from the UNI GeoTREE Center 
(Spring 2018) 

Contact: John DeGroote, john.degroote@uni.edu, 319-273-6158.  

 

Ricoh Theta V 

 

The Ricoh Theta V is a 360⁰ camera comprised of two 180⁰ fish eye lenses. These fish eye lenses 
automatically stich together two separate photos in order to achieve the 360⁰ effect. For our purposes, 
we will consider the image below to be the back of the camera. 

 

Camera Setup 

1. Buttons  
o Back 

 Capture  
• This button is used to capture images. For our project, we will not be 

using this button. 
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o Left Side 
 Power  

• Located at the top, this button powers on/powers off the camera. 
 WiFi  

• Located in the middle, this button is used to turn on the camera’s 
internal WiFi, necessary for connecting a smart device to the camera. 

 Photo/Video toggle 
• Located at the bottom, this button is used to switch between photo and 

video modes. For this project, we will only be using photo mode. 

 

 

Necessary Apps to Download 

1. You will need to download the Ricohh Theta S app from your respective app downloading service 
(Google Play, Apple Store) in order to capture photos on the Ricoh Theta V from your smart device.  

a. The Ricoh Theta app will automatically create a folder where your 360⁰ photos will be 
stored. This folder will be created in your smart device’s default photo gallery.   

 

 

 

 

 

 

 

 



 

2. You will potentially need this app depending on your role (just taking photos or taking photos 
and publishing to Street View). The Google Street View app is used to publish images to Google 
servers where they will appear on Google Street View. Publishing to Street View requires a 
Gmail account (UNI account works).   

 
 

 
Connecting your Smart Device to the Ricoh Theta V 
 
 
1. Begin by powering on the camera 

a. Three blue lights should appear on the front of the camera: One small dot above the 
capture button, a blinking WiFi symbol, and a camera. Ensure that the camera mode 

 is selected and not the video mode  by pressing the toggle button on the 
right side of the camera. If the WiFi symbol is not lit, tap the button on the right side 
that enables the internal WiFi.  
 

2. Next, connect to the camera through your smart device’s WiFi settings by selecting 
“THETAXS00288025” (this was written for use at UNI GeoTREE Center, you will have a 
different #). If this is your first time connecting, you will need to enter the serial number as 
the password. The serial number are the numbers subsequent to the “THETAXS”, in this 
case, 00288025. This number can be found on the bottom of your camera or in the WiFi 
settings.   

a. NOTE: You will not be able to connect or use the internet on your smart device if 
you are connected to the camera.  
 



3. You are now connected to the Ricoh Theta V. 
 

Capturing Photos in the Ricoh Theta App 

1. Open the Ricoh Theta app on your smart device. 
2. If the app doesn’t open in camera mode automatically, you can access it by pressing the small 

Ricoh Theta logo located at the bottom right of your screen, as seen below. 
 

 

3. Once you’ve clicked   and see the screen below, you’re ready to capture an image from 
your smart device by pressing the large white button located at the bottom of screen.  

 
 
 



 
 

4. After you take this photo, your image will take a few seconds to synthesize (process) and then 
be stored on both your phone and on the Ricoh Theta V device itself. The Ricoh Theta app will 
automatically create an album/folder titled “RICOC THETA” in your image gallery on your smart 
device. 
 
 
 

Mounting Camera to Tripod 
 

1. Extend the tripod legs by loosening the bottom bolt on the center bracket and pushing down on 
that bracket. Ensure that your tripod legs look similar to the photo posted below. Note that this 
is taken at an angle and you want the tripod standing straight up.   

2. Extend the tripod by undoing the two snaps and pulling up on the mount. Snap the two snaps 
back into place once the tripod is fully extended.  



 

 
3. Line up the threads on the bottom of the Ricoh Theta V with the top bolt of the tripod 
4. Twist in a clockwise fashion until camera is snugly fastened to the tripod. Do not over tighten 

the camera, only twist until you’re met with resistance.  
 
 

Method for Google Street View Capture 
 

1. After connecting your smart device to the Ricoh Theta V and you’ve mounted the camera on the 
tripod, you’re ready to capture photos for Google Street View.  

2. There is no need to capture sidewalks that are next to streets, as Google has most likely 
captured the images along the street with their Street View car.  

3. WHEN GOING OUTSIDE, ALWAYS KEEP A HAND ON THE TRIPOD IF THE CAMERA IS ATTACHED 
TO IT! The wind is liable to knock the tripod and camera over, breaking the camera. Always have 
a hand on the tripod at all times.  

4. Find a starting location. 
5. Make sure the front of the camera is facing in the direction that you will move.   
6. Crouch down next to the tripod with one arm around the tripod in order to make sure it doesn’t 

tip over. By being below the camera it will make it easier to edit you out later before publishing. 

Snaps 

Bottom Bolt 

Top Bolt 



AGAIN, WHILE CROUCHING, HUG THE TRIPOD OR KEEP A HAND ON IT to make sure it doesn’t 
tip. 

7. Capture your first image as you did in steps above. Again it will take a few moments to 
process/synthesize.  

 
8. Count off 10 steps in the direction of which you want to proceed. NOTE: Google Street View 

instructions suggest one photo for every 10 feet when capturing images outside, which equates 
to 5 steps for the average person. In our practical experience 10 normal steps will work fine.  

9. Make sure to capture the intersections of pathways, as we may be capturing the sidewalks that 
intersect your current path at a later date.  It is ok if you’re step count is under the required 10 
steps or if it’s over up to 3 steps as long as you catch the intersection.  

10. Have a little fun with this as well. If you see a scenic shot, don’t be afraid to take it. 
11. Once you’ve captured the images you want, it’s time to edit the pictures. 

 

Editing Photos in Adobe Photoshop 

1. Connect your smart device to your computer by using a USB cable.  
a. Make sure your device is unlocked and accessible to the computer. 

2. Open Adobe Photoshop by going to Start Menu > All Programs > Adobe Creative Cloud > Adobe 
Photoshop. 

3. In Adobe Photoshop, click on the File > Open. 
a. You should be prompted with a file explorer window. 
b. Navigate to your smart device which should be located in This PC and under Devices 

and Drives. Double click on your smart device. 

 
 
 
 
 



 
 
 
 

c. Double click again to access the hard drive. 

 
d. Navigate to the file where your “RICOH THETA” folder is located. This is generally in 

either a folder titled “Pictures” or “DCIM”. 
e. Select the first photo you wish to edit and then click Open. NOTE: You should edit and 

save these photos in the order you captured them. This helps to keep these photos 
organized.   

f. Your photo should open in Adobe Photoshop. 
4. You should have something similar to the image below opened up. 

 
 

 
 



 
 

5. First, we want to check the image for any red dots that have appeared in the image. There may 
be 2 red dots and they can generally be found near the left and right edges of the photo. We’ve 
found one here near the left edge of the image.  

 
 

6. Zoom in on the dot using the Zoom Tool  located on the left side of the Photoshop 
window, near the bottom. Click, hold, and drag to zoom in and out.  

7. When you’re zoomed in comfortable, select the Clone Stamp Tool  on the left side of the 
Photoshop window.  

a. You can change the size of the Clone Stamp Tool by clicking on the Clone Stamp Brush 

Preset picker near the top left of your screen  
b. When the Clone Stamp Tool is selected and set to the desired size, hover it over a 

section of the image you would like to use to “clone” over the red dot. For instance, the 
red dot in the above image is located on a shadowy patch of cement, so I would want to 
hover the Clone Stamp Tool over a section of shadowy cement.  



c. Press and hold the Alt key on your keyboard. Your Clone Stamp Tool should change from 
a circle to a circle with crosshairs. 

d. Click on the area that you wish to clone and then release the Alt key. 
e. You should now hover your Clone Stamp Tool above the red dot, right click and hold, 

and begin to brush away the red dot. 
f. You’ll notice a small + sign will appear and begin to follow your brushes near where you 

selected an area to clone with the Alt key. This is the area that is being cloned, so if that 
+ sign goes over a leaf, a leaf will be cloned onto where you’re brushing.  

g. If you make any mistakes, hold Ctrl + Alt and then tap the Z key as many times as you 
wish to undo your mistakes. 

8. Once the red dots are removed, we can now remove yourself and the tripod from the photos. 
a. Begin my selecting the Image drop down menu and selecting Image Rotation > 180⁰ 

 
b. After the image has been rotated, go to the top of the window and click Filter > Distort 

> Polar Coordinates  



 
c. The Polar Coordinates window appears. 

i. Make sure that Rectangle to Polar is selected and click OK. 
d. The photo should now look similar to the image below. This gives us a floor plan layout 

to work with. 

 
 

e. Zoom in on yourself and the tripod. 

f. Select the Lasso Tool  on the left side of the Photoshop window. 
g. While this tool is selected, click and hold while tracing around the outline of your body 

and shadow. 



 

  

h. When you outlined around yourself, release your mouse button. Your outline should be 
highlighted like the image below. 

 
 

i. Press the Delete key on your keyboard. You should be prompted with the Fill dialog 
window. 



 
 

j. Ensure that Contents: selection is set to Content-Aware and that Mode is set to Normal 
and Opacity is set to 100. Click OK. 

k. You should now be removed from the image. NOTE: If need be, the Clone Stamp Tool 
can be used to touch up the area if anything looks severely out of place.  

 
l. Make sure to click anywhere in the image once to remove the Lasso Tool outline and 

complete the removal of yourself. 
9. Now we need to set the image back to its original settings so it can be saved and later uploaded 

to Google Street view. 
a. Select Filter > Distort > Polar Coordinates again to open the Polar Coordinates dialog.  
b. This time, change the selection to Polar to Rectangle and select OK.  



 
c. The image should be back to its 180⁰ rotation. 
d. Next, go and select Image > Image Rotation > 180⁰ to set your return your photo back 

to 360⁰ format. 
10. Now you can save the image by going to File > Save As and selecting or creating a folder of your 

choice to begin saving your photos in. As stated before, edit and save these photos in order of 
which you captured them. Name them systematically, such as “Camp_1, Camp_2, Camp_3…..” 
just as long as we know what general order to follow with these photos. This allows us to better 
manage the photos in Google Street View if photos need to be removed or manually placed in 
their location.  

Uploading Edited Photos Back to your Smart Device  

1. When you have your 20 photos edited and saved to your folder, you’re ready to upload those 
photos back to your smart device.  

2. You’ll want to create a new folder in your Phones “PICTURES” folder and name it something of 
your choice. 

a. Right click when in the “PICTURES” folder, and select New Folder. 
b. Title it as you wish. 

3. Select the edited 360⁰ images you wish to upload back to your smart device, right click and copy 
or you can drag and drop. 

4. Paste the images in the folder you created. Your edited 360⁰ photos are now back on your 
device.  

Uploading Images to Google Street View 

NOTE: It’s generally easier to manage these photos in Google Street View by editing and 
uploading only 20 photos at a time. If you upload many photos at once, they will be hard to find 
and place in their correct spots.  



 

1. Open the Google Street View app that you had previously downloaded on your smart device.  
a. Make sure your smart device is disconnected from the Ricoh Theta V. 

2. Near the top of the window, select the Private tab. 

 
3. Near the bottom right of the screen, you’ll notice a small orange circle with a camera in it. Tap 

on that camera. NOTE: If the circle is blue, you are still connected to the Ricoh Theta V and need 
to disconnect. 

4. You’ll be presented with 3 options, choose Import 360 photos. 

 
5. Depending on the smart device you’re using, you may need to navigate to the folder/album that 

you created to save your 360⁰ images. 



6. When you’ve navigated to that folder, press and hold the first image you wish to upload until a 
check mark appears next to the image’s file name. From here, you can tap on the rest of the 20 
photos you wish to upload. 

 
7. When All are selected, tap OPEN near the top right of your screen. 
8. The photos will be imported to your private section and will not be available to the public until 

you publish them.  
9. From here, you can pick and choose a map listing by tapping on the “Add a Maps listing” 

selection. This enables you to add a listing of your choice which keeps your photos grouped 
together.  

           
 



10. You can also edit the location of your photo by tapping the 3 dots next to the upload selections 
and tapping Select all and then again tapping the 3 dots and selecting Edit locations. This will 
also allow you to edit the locations of your photos, which may be necessary if you’re phone 
wasn’t receiving an adequate GPS signal during the time the photo was captured. 

                   
 

11. Tap and manually move photos to appropriate locations on the map. Make sure to zoom in and 
place them directly on the path where they were taken. 

12. It may help to switch to satellite imagery for visual references of where your photos need to go. 

 
 



13. When finished, tap the check mark on the top right of your screen, or click back to go back and 
cancel changes.  

 
14. When you’re satisfied with your map listing and photo locations, tap the Publish All selection in 

the Private tab section. 

 
15. Your photos are now uploaded to Google Street View and will be available for display on 

desktop after the appropriate processing time.  

 

Trouble Shooting 

1. If any problems are encountered when trying to connect a smart device to the Ricoh Theta V 
camera, restart both the camera and smart device. 



 
 


